Server crash TTT Linux

Author Topic: Server crash TTT Linux  (Read 2969 times)

Offline Moe

  • *
  • Posts: 5
    • View Profile
    • Awards
Server crash TTT Linux
« on: July 16, 2015, 10:30:39 PM »
I had this linux vps and decided to install a gmod TTT server on it. The server runs when its on gm_flatgrass but crashes if more than one player try to join. When I try to start it in de_dolls for TTT it wont start just crashes. I have been trying to fix this for 3 days now and got nothing. Thanks
debug.log
Code: [Select]
----------------------------------------------
CRASH: Thu Jul 16 22:29:49 EDT 2015
Start Line: ./srcds_linux -debug -game garrysmod +maxplayers 16 +map de_dolls +$
End of Source crash report
----------------------------------------------

Console Crash
Code: [Select]
Auto detecting CPU
Using default binary: ./srcds_linux
Enabling debug mode
Server will auto-restart if there is a crash.

Console initialized.
Adding Path: [/home/tf2server/counterstrikesource/cstrike]
FIND [/home/tf2server/counterstrikesource/cstrike/*.vpk]
ADDING [/home/tf2server/counterstrikesource/cstrike/cstrike_pak_000.vpk]
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Logging into anonymous gameserver account.
Fetching Workshop Addons.. host_workshop_collection is unset
Adding Filesystem Addon '/home/tf2server/serverfiles/garrysmod/addons/scars'
Adding Filesystem Addon '/home/tf2server/serverfiles/garrysmod/addons/addons'
Adding Filesystem Addon '/home/tf2server/serverfiles/garrysmod/addons/pointshop-master'
Adding Filesystem Addon '/home/tf2server/serverfiles/garrysmod/addons/ulib'
Adding Filesystem Addon '/home/tf2server/serverfiles/garrysmod/addons/ulx'
Changing gamemode to Trouble in Terrorist Town (terrortown)
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Network: IP 23.94.108.44, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
PREP OK
HTTP failed - ISteamHTTP isn't available!
///////////////////////////////
//      Ulysses Library      //
///////////////////////////////
// Loading...                //
//  shared/defines.lua       //
//  shared/misc.lua          //
//  shared/util.lua          //
//  shared/hook.lua          //
//  shared/table.lua         //
//  shared/player.lua        //
//  server/player.lua        //
//  shared/messages.lua      //
//  shared/commands.lua      //
//  server/concommand.lua    //
//  server/util.lua          //
//  shared/sh_ucl.lua        //
//  server/ucl.lua           //
//  server/phys.lua          //
//  server/player_ext.lua    //
//  server/entity_ext.lua    //
// Load Complete!            //
///////////////////////////////
[ULIB] Loading SHARED module: ulx_init.lua
///////////////////////////////
//       ULX Admin Mod       //
///////////////////////////////
// Loading...                //
//  sh_defines.lua           //
//  lib.lua                  //
//  base.lua                 //
//  sh_base.lua              //
//  log.lua                  //
//  MODULE: slots.lua        //
//  MODULE: uteam.lua        //
//  MODULE: votemap.lua      //
//  MODULE: xgui_server.lua  //
///////////////////////////////
// ULX GUI -- by Stickly Man //
///////////////////////////////
// Adding Main Modules..     //
//  bans.lua                 //
//  commands.lua             //
//  groups.lua               //
//  maps.lua                 //
//  settings.lua             //
// Adding Setting Modules..  //
//  client.lua               //
//  server.lua               //
// Adding Gamemode Modules.. //
//  sandbox.lua              //
// Loading Server Modules..  //
//  sv_bans.lua              //
//  sv_groups.lua            //
//  sv_maps.lua              //
//  sv_sandbox.lua           //
//  sv_settings.lua          //
// XGUI modules added!       //
///////////////////////////////
//  MODULE: chat.lua         //
//  MODULE: fun.lua          //
//  MODULE: menus.lua        //
//  MODULE: rcon.lua         //
//  MODULE: teleport.lua     //
//  MODULE: user.lua         //
//  MODULE: userhelp.lua     //
//  MODULE: util.lua         //
//  MODULE: vote.lua         //
//  end.lua                  //
// Load Complete!            //
///////////////////////////////
Included TTT language file: chef.lua
Included TTT language file: english.lua
Included TTT language file: german.lua
Included TTT language file: portuguese.lua
Included TTT language file: russian.lua
Included TTT language file: spanish.lua
Included TTT language file: swedish.lua
Included TTT language file: tradchinese.lua
Trouble In Terrorist Town gamemode initializing...
This is TTT version 2015-05-25
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file server.cfg
Using map cycle file 'cfg/mapcycle_default.txt'.  ('cfg/mapcycle.txt' was not found.)
Killed
cat: hlds.18345.pid: No such file or directory
email debug.log to linux@valvesoftware.com
Thu Jul 16 22:29:49 EDT 2015: Server restart in 10 seconds
Thu Jul 16 22:29:51 EDT 2015: Server Quit

Offline Somone77

  • Developer
  • *
  • Posts: 653
    • View Profile
    • Awards
Re: Server crash TTT Linux
« Reply #1 on: July 16, 2015, 11:28:02 PM »
Has something to do with the PID lock file not being found, obviously. I would try running the server as root (just as a test, don't run it this way publicly) and see if the problem happens. If it does, I would use steamcmd to validate the gmod install. Otherwise it may just be a permissions error.

Offline Moe

  • *
  • Posts: 5
    • View Profile
    • Awards
Re: Server crash TTT Linux
« Reply #2 on: July 17, 2015, 01:14:07 AM »
Has something to do with the PID lock file not being found, obviously. I would try running the server as root (just as a test, don't run it this way publicly) and see if the problem happens. If it does, I would use steamcmd to validate the gmod install. Otherwise it may just be a permissions error.

When I ran as root it still crashed and also had errors with mounting.

 

SimplePortal 2.3.7 © 2008-2020, SimplePortal